Opened 17 months ago

Closed 17 months ago

Last modified 9 months ago

#1089 closed defect (fixed)

Weird nat64 network behavior

Reported by: furry13@… Owned by: panda@…
Priority: tbd Milestone: ietf-098
Component: nat64 Keywords:
Cc: My Current Location:
My MAC Address: My OS:

Description

Hi guys,

Lorenzo and I are seeing smth very weird while connecting to nat64 SSID.
I'm attaching .pcap file but let me explain what's happening:

- my laptop connects to wifi, sends and RS (packet #4), gets an RA (packet #33).
The RA contains RDNSS info and PIO, so my host configures LLA and two
GUAs (performing DAD) and then starts sending DNS requests (packets
#47 ...)
No response. At some point (packet #144) my host sends NS for the
router address (fe80::1998:1), gets a response, keeps sending DNS
requests - no response.
Then, suddenly, after ~11 seconds after sending the very first RS
(packet #4 mentioned above), my host receives two DAD packets for its
own GUAs (packets #265 and 267) sent by some Cisco device (MAC
address: 00:3a:7d:71:93:89).
My host responds and suddenly everything starts working - my host is
getting DNS responses back etc....

Any idea what it is?

-- 
SY, Jen Linkova aka Furry

nat64-1.pcap

Attachments (2)

nat64-1.pcap (352.1 KB) - added by furry13@… 17 months ago.
Added by email2trac
wifi.png (68.2 KB) - added by furry13@… 17 months ago.
Added by email2trac

Download all attachments as: .zip

Change history (10)

Changed 17 months ago by furry13@…

Attachment: nat64-1.pcap added

Added by email2trac

comment:1 in reply to:  2 Changed 17 months ago by furry13@…

My wifi association info attached (I've just reproduced it from the
lobby but was seeing the same in Zurich E/F earlier)

On Mon, Mar 27, 2017 at 10:49 PM, IETF Tickets/NOC
<tickets@meeting.ietf.org> wrote:
> #1089: Weird nat64 network behavior
> ----------------------------+-----------------------------------
>       Reporter:  furry13@…  |                Owner:  < default >
>           Type:  request    |               Status:  new
>       Priority:  tbd        |            Milestone:  ietf-98
>      Component:  incoming   |           Resolution:
>       Keywords:             |  My Current Location:
> My MAC  Address:            |                My OS:
> ----------------------------+-----------------------------------
> Changes (by furry13@…):
>
>  * Attachment "nat64-1.pcap" added.
>
>  Added by email2trac
>
> --
> Ticket URL: <https://tickets.meeting.ietf.org/ticket/1089>
> IETF Tickets/NOC <https://tickets.meeting.ietf.org>
> IETF Meeting Tickets - NOC pages



-- 
SY, Jen Linkova aka Furry

wifi.png

Changed 17 months ago by furry13@…

Attachment: wifi.png added

Added by email2trac

comment:2 Changed 17 months ago by llynch@…

Component: incomingnat64
Owner: changed from < default > to panda@…
Status: newassigned
Type: requestdefect

comment:3 in reply to:  5 Changed 17 months ago by lorenzo@…

See also the ticket I filed here:

https://tickets.meeting.ietf.org/ticket/1080#comment:2

On Mon, Mar 27, 2017 at 3:49 PM, Jen Linkova <furry13@gmail.com> wrote:

> Hi guys,
>
> Lorenzo and I are seeing smth very weird while connecting to nat64 SSID.
> I'm attaching .pcap file but let me explain what's happening:
>
> - my laptop connects to wifi, sends and RS (packet #4), gets an RA (packet
> #33).
> The RA contains RDNSS info and PIO, so my host configures LLA and two
> GUAs (performing DAD) and then starts sending DNS requests (packets
> #47 ...)
> No response. At some point (packet #144) my host sends NS for the
> router address (fe80::1998:1), gets a response, keeps sending DNS
> requests - no response.
> Then, suddenly, after ~11 seconds after sending the very first RS
> (packet #4 mentioned above), my host receives two DAD packets for its
> own GUAs (packets #265 and 267) sent by some Cisco device (MAC
> address: 00:3a:7d:71:93:89).
> My host responds and suddenly everything starts working - my host is
> getting DNS responses back etc....
>
> Any idea what it is?
>
> --
> SY, Jen Linkova aka Furry
>

comment:4 Changed 17 months ago by panda@…

Status: assignedaccepted

Hi,

Thank you for the report.

As Lorenzo mentioned, this issue is caused by the same feature of Wireless LAN Controller as the following ticket that is reported by Lorenzo. Currently, we are trying to find a way to solve these issue but have not yet found. I'll update both tickets when we find anything.
https://tickets.meeting.ietf.org/ticket/1080#comment:4

Thank you.
Hirochika Asai

comment:5 Changed 17 months ago by panda@…

Hi,

We enable the unknown address multicast NS forwarding on WLC so that NS packets can be forwarded before WLC completes proxy DAD. This does not disable WLC's weird DAD but should fix the issue that you loses packets for the first several seconds.

Could you please check if the issue is solved?

Thank you.
Hirochika Asai

comment:6 in reply to:  8 Changed 17 months ago by furry13@…

It works now, thanks a lot!

On Tue, Mar 28, 2017 at 3:18 PM, IETF Tickets/NOC
<tickets@meeting.ietf.org> wrote:
> #1089: Weird nat64 network behavior
> ----------------------------+--------------------------------
>       Reporter:  furry13@…  |                Owner:  panda@…
>           Type:  defect     |               Status:  accepted
>       Priority:  tbd        |            Milestone:  ietf-98
>      Component:  nat64      |           Resolution:
>       Keywords:             |  My Current Location:
> My MAC  Address:            |                My OS:
> ----------------------------+--------------------------------
>
> Comment (by panda@…):
>
>  Hi,
>
>  We enable the unknown address multicast NS forwarding on WLC so that NS
>  packets can be forwarded before WLC completes proxy DAD.  This does not
>  disable WLC's weird DAD but should fix the issue that you loses packets
>  for the first several seconds.
>
>  Could you please check if the issue is solved?
>
>  Thank you.
>  Hirochika Asai
>
> --
> Ticket URL: <https://tickets.meeting.ietf.org/ticket/1089#comment:5>
> IETF Tickets/NOC <https://tickets.meeting.ietf.org>
> IETF Meeting Tickets - NOC pages



-- 
SY, Jen Linkova aka Furry

comment:7 Changed 17 months ago by panda@…

Resolution: fixed
Status: acceptedclosed

Hi Furry,

Thank you for checking it. We'll close this ticket as this issue is fixed.

Best,
Hirochika Asai

comment:8 Changed 9 months ago by Rick Alfvin

Milestone: ietf-98ietf-098

Milestone renamed

Note: See TracTickets for help on using tickets.