Opened 7 years ago

Closed 6 years ago

Last modified 5 weeks ago

#375 closed request (fixed)

802.1X not working

Reported by: bless@… Owned by: nweis@…
Priority: tbd Milestone: ietf-080
Component: wireless Keywords:
Cc: My Current Location: congress Hall I
My MAC Address: 00:21:6a:71:cc:cc My OS: Linux 2.6.35-28

Description

I couldn't succesfully authenticate to any 802.1X network, e.g.,
ietf.1x ietf-a.1x or eduroam. That already worked two hours ago...

Attachments (1)

ietf80-auth-problems.txt (12.9 KB) - added by bless@… 7 years ago.
testual packet dump of 801.X authentication attempts (finally successful)

Download all attachments as: .zip

Change history (13)

comment:1 Changed 7 years ago by jim@…

I'm able to authenticate to ietf-a.1x with ietf/ietf with no problem. I've checked our radius servers, and we're getting a regular stream of successful auths. This might be a client issue on your side (though, there's certainly the chance that we've got an issue hiding somewhere). When you have a moment, come by the Help Desk and we'll be glad to look more deeply at your issue.

  • Jim

comment:2 Changed 7 years ago by bless@…

Hi Jim, thanks for the quick response.
Right now it's working again. I had also problems with IPv6 connectivity (couldn't even ping the default router) and IPv4 (massive packet drops). However, everythings seems to work again right now, I also could reconnect to the ietf-a.1x network to where I'm attached right now. I didn't change anything on my side though...strange

comment:3 Changed 7 years ago by jim@…

How's your signal strength? I'm wondering if this is a RF-side issue. You're still in Congress I?

comment:4 in reply to:  3 Changed 7 years ago by anonymous

Replying to jim@…:

How's your signal strength? I'm wondering if this is a RF-side issue. You're still in Congress I?

Seemed to be ok all the time. However, I was disassociated from the ietf-a.1x
and I'm experiencing problems right now again. Same for a colleague of mine.

wlan0 IEEE 802.11abg ESSID:"ietf"

Mode:Managed Frequency:2.412 GHz Access Point: 00:17:DF:AA:55:F1
Bit Rate=54 Mb/s Tx-Power=14 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=70/70 Signal level=-38 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

comment:5 Changed 7 years ago by llynch@…

Component: incomingwireless
Owner: changed from llynch@… to nweis@…
Status: newassigned

comment:6 Changed 7 years ago by nweis@…

Greetings,

I'm trying to locate your mac address on our network and do not currently see it.

Is 00:21:6a:71:cc:cc the correct mac address?

comment:7 Changed 7 years ago by bless@…

Yes, it is, but I was offline at the welcome reception, so pretty clear that you couldn't see the address :-)
We could resume this tomorrow...

comment:8 Changed 7 years ago by bless@…

So this morning everything worked quite nicely, no single disassociation.
Since noon, however, I was experiencing some problems in Congress Hall III.
It seems, that my client tries to re-authenticate which doesn't work properly.
I'm now in Vienna/Madrid? and right now everything works after initial problems.
It seems that my 801.x client needs a TLS failure to start over properly.
I'll attach a packet text dump where one may see the problem in more detail.
Not clear where cause of the problem is exactly, e.g., whether this is an implementation
or interoperability problem.
From the dump it is, however, obvious that the TLSv1 Change Cipher Spec message doesn't get a reply
from the AP.

Changed 7 years ago by bless@…

Attachment: ietf80-auth-problems.txt added

testual packet dump of 801.X authentication attempts (finally successful)

comment:9 Changed 6 years ago by nweis@…

Resolution: fixed
Status: assignedclosed

comment:10 Changed 5 years ago by Enlatadreania

comment:11 Changed 5 years ago by anonymous

healthy eating in pregnancy pregnancy diet checklist For those who lack the time to hit the gym, this HCG diet drops is the safest option for them. sweefrituccut

comment:12 Changed 5 weeks ago by Rick Alfvin

Milestone: ietf-80ietf-080

Milestone renamed

Note: See TracTickets for help on using tickets.